CMS Snapshot Analysis - Compute Snapshot - Fatal Error - Error while executing Procedure - function cast_logstart unknown does not exist

Purpose (problem description)

This page outlines the issue where snapshot fails at compute snapshot step with the below mentioned error:

ERROR: function cast_logstart(unknown) does not exist
            Hint: No function matches the given name and argument types. You might need to add explicit type casts.

            Where: PL/pgSQL function diag_dotnet_inherit_level(integer,integer,integer) line 9 at PERFORM
            PL/pgSQL function diag_scope_netemem008(integer,integer,integer,integer) line 15 at assignment
            org.postgresql.util.PSQLException:ERROR: function cast_logstart(unknown) does not exist

Observed in CAST Version

ReleaseYes/No
<8.3.16✅

Observed in RDBMS

RDBMSYes/No
Oracle Server❌
Microsoft SQL Server✅
CSS3✅
CSS2✅

Step by Step scenario

  1. Run snapshot
  2. Observe it failed at compute snapshot step

Action Plan

If your snapshot failed with above mentioned error then, perform the below action :

  1. This issue is observed when latest version of .Net extension is used with AIP version <8.3.16 ( This is mainly observed with .Net version 1.3.0-beta1)

    1. If your AIP version is <8.3.16 and .Net version is 1.3.0 beta1 then please apply the below work around to fix this issue.
      1. Apply the attached procedure fix on local schema followed by a snapshot skipping analysis.

    This is a known issue where latest DotNet extensions are not compatible with AIP version <8.3.16( Mainly observed with .Net version 1.3.0-beta1)
    This is due to the fact that the procedures cast_logstart and cast_logend are introduced since 8.3.16. So if the user uses an AIPversion < 8.3.16 with extensions calling cast_logstart and cast_logend then the snapshot will not complete.

  2. If the above steps do not solve your issue contact CAST Technical Support. with the following Relevant input

 

Relevant input

Notes/comments

Ticket # 25323

Related Pages